คุณไม่ได้ไปต่อ !! Android P จะไม่ให้แอปฯ ที่ทำขึ้นมาสำหรับ Android 4.1 หรือต่ำกว่าทำงานได้อีกต่อไป

ในเมื่อ Apple เองก็จัดการให้แอปพลิเคชั่นเก่าๆ ซึ่งไม่รองรับ iPhone หรือ Hardware รุ่นใหม่ๆ ทิ้งแล้วทำไมข่าวนี้จะเกิดขึ้นกับทางฝั่ง Android หรือ Google บ้างไม่ได้ ซึ่งล่าสุดบน Android P ได้มี API ใส่เอาไว้ไม่ให้เราสามารถใช้งานแอปพลิเคชั่นที่ไม่มีการพัฒนาหรือแอปพลิเคชั่นเก่าๆ ได้อีกต่อไป

ทุกๆ แอนดรอยด์เวอร์ชั่นใหม่จะมีการนำเสนอถึงการเปลี่ยนแปลงในการอนุญาตให้แอปสามารถทำงานได้อย่างไรอยู่แล้ว ยกตัวอย่างเช่น Android 6.0 Marshmallow ที่มีฟีเจอร์ Doze ที่จะทำให้ตัวเครื่องจำกัดการแจ้งเตือนเพื่อประหยัดแบตเตอรี่ในกรณีที่เราวางเครื่องทิ้งไว้นานๆ อาทิเช่น ขณะนอนหลับ ซึ่งสำหรับเคสนี้หากแอปพลิเคชั่นไม่อัพเดทและไม่รองรับ Doze แล้วก็จะทำให้เราไม่สามารถใช้ฟีเจอร์ใหม่ๆ ของแอนดรอยด์ได้อย่างเต็มที่

นี่คงเป็นสาเหตุที่ Android P Developer Preview ได้มีการแสดงข้อความว่า “This app was build for an older version of Android and may not work properly. Try checking for updates, or contact the developer.” เมื่อเราได้ทำการเปิดแอปฯ เก่า ทำให้ไม่สามารถใช้งานแอปเก่าๆ ได้ ซึ่งตรงนี้ยังมีจุดที่ไม่ชัดเจนเพราะไม่แน่ว่าในอนาคตตัว Final อาจจะยอมให้ใช้แอปเวอร์ชั่นเก่าๆ ก็เป็นได้

ที่มา AndroidPolice

ถูกใจบทความนี้  14

ใส่ความเห็น